Hoşgeldin. Soru sormak veya cevaplamak için hemen üye ol.
0 oy
201 kez görüntülendi
ios development kategorisinde tarafından

Indicator için kullandığım bir sınıf var. Şuradaki satırda
https://github.com/KyoheiG3/SpringIndicator/blob/master/SpringIndicator/SpringIndicator.swift#L28

şöyle bir sorun çıkıyor:

Method 'initialize()' defines Objective-C class method 'initialize', which is not guaranteed to be invoked by Swift and will be disallowed in future versions

Yardımcı olabilir misiniz?

1 cevap

0 oy
tarafından

library'yi Cocoapods kullanarak mı dahil ettin projeye?

tarafından

Hayır üstadım. Kopyaladım projemin içine. O şekilde kullandım. Şimdiye kadar sorun yoktu. Xcode 8.3'te bu hata çıktı. Aramalarım sonucunda so'da bir şeyler buldum:

http://stackoverflow.com/questions/42824541/swift-3-1-deprecates-initialize-how-can-i-achieve-the-same-thing

Ama ben bu çözümü, bu library için projemde nasıl uygulayacağımı anlayamadım açıkçası.

...