Hoşgeldin. Soru sormak veya cevaplamak için hemen üye ol.
0 oy
386 kez görüntülendi
ios development kategorisinde tarafından

Uygulamamı, UIActivityViewController email gönderme işlemleri esnasında, smilatörde 8.1 ile  iPhone 4S'te test ediyorum.  Şu kodları kullanıyorum:
 

if let textLink = NSURL(string: "http://forum.yasinturkoglu.com") {

            let textToShare = "Merhaba, forum.yasinturkoglu.com IOS platformuna uygulama geliştiren veya ilgi duyanların sorularını ve cevaplarını paylaşabilecekleri bir paylaşım ağıdır. IOS geliştiriciliği ve ilgili konularıyla alakalı sorularınızla merakınızı, cevaplarınızla merakları giderin."

            let activityVC = UIActivityViewController(activityItems: [textToShare], applicationActivities: nil)

            activityVC.setValue("IOS geliştiricileri paylaşım ağı", forKey: "subject")

            self.presentViewController(activityVC, animated: true, completion: nil)

        }

Ve ardından Email'i seçiyorum ve açar açmaz hata çıkıyor, hatta Xcode beklenmedik şekilde çöküyor:

viewServiceDidTerminateWithError: Error Domain=_UIViewServiceInterfaceErrorDomain Code=3 "The operation couldn’t be completed. (_UIViewServiceInterfaceErrorDomain error 3.)" UserInfo=0x7ba42050 {Message=Service Connection Interrupted}

 <MFMailComposeRemoteViewController: 0x7c8a2800> timed out waiting for fence barrier from com.apple.MailCompositionService


Bu sorunu nasıl çözebilirim. Uygulamam iOS 7 ve üzeri cihazlar için olacak.

 

1 cevap

+1 oy
tarafından
tarafından seçilmiş
 
En İyi Cevap

emin olamadım ama hatayı aratınca stackoverflow'da şu cevaba rastladım.
http://stackoverflow.com/a/26001706/1251846
simulator'de ios8 ve üzerinde bug olduğundan bahsedilmiş bu konuyla ilgili. gerçek cihazda bir test edin.

tarafından
Teşekkür ederim. Gerçek cihazda iOS 8.4 yüklü. Tam olarak nasıl bir test yapabilirim, iOS 8.1'de ne olabileceği hakkında ?
tarafından
8.4 yüklü cihazda bu hata olmuyor test edince.  Simulatöre özgü deniyor ama, kesin bir bilgi değil ? 8.1'de, 8.2'de gerçek cihazda nasıl test edebilirim sizce, kullanıcıların böyle bir hata ile karşılaşıp karşılaşmayacaklarını. iOS 8.4 yüklü cihazıma eski versiyonları yükleyebilir miyim ? Ya da farklı bir yolu var mı :)
tarafından
+1
yok eski versiyon IOS yükleyemezsiniz cihazınıza. ios8.1 yüklü bir cihaz bulmalısınız o zaman.
tarafından
Teşekkür ederim. Epey zorlu ve maliyetliymiş bu test işleri o zaman değil mi ? : )
tarafından
+1
evet, bütün cihazlarınızı hemen üst IOS versiyonlarına güncellemeyin. :)
tarafından
Anladım. Ama iş işten geçti benim için :) Bir iPhone var 4S 8.4'lü ve bir de iPad var onda da 8.3 yüklü :) Eşe dosta haber salıcam artık çare yok.

Siz uygulama geliştiriken 7. üzeri mi çalışıyorsunuz. Pazar payına göre ios 8. %85 felan diyorlar doğru mu ?
Ben sadece ios 8.3 ve üzeri mi takılsam acaba ? Çok şey kaybeder miyim sizce :)
...