Hoşgeldin. Soru sormak veya cevaplamak için hemen üye ol.
0 oy
292 kez görüntülendi
genel kategorisinde tarafından

İos 8 için hazırladığım uygulama ios 9 veya 10 da çalışırken sıkıntı çıkartırma veya bunu nasıl anlayabiliriz ?

1 cevap

+1 oy
tarafından
tarafından seçilmiş
 
En İyi Cevap

lütfen sorularınızı muğlak ifadelerden kaçınarak daha net ve anlaşılır bir şekilde sormaya gayret ediniz.

tarafından

yazacağım uygulamaya en başında doğru alt yapı kullanmak için böyle bir soru sordum örnek olarak şöyle bir uygulama hazırlıyorum diyelim "gittiğin yerlerin fotosunu çekip birde açıklama ekleyen günlük" , bu uygulamayı 3 farklı kullanıcı indirdi
telefonlarındada ios 8 ios 9 ve ios 10 yüklü diyelim bunlardan birinde çalışmama gibi bir durum söz konusu olabilirmi ? yani böyle sordum soruyu

Yada şöyle bir şey söz konusumu;
Uygulamayı appstore yüklerken farklı ios versiyonlarıyla yükleyebiliyormuyuz?

tarafından

uygulamanın destekleyeceği minimum ios sürümünü xcode içerisinde targets/general sayfasında yer alan deployment target alanından belirleyebiliyoruz.
örneğin bu alanda ios sürümünü 8.0 yaptığınızda.
uygulamanız appStore'a yüklendiğinde sadece ios8 ve üzeri versiyonlara sahip cihazlar için indirilebilir olacaktır.
Her ios sürümünde muhakkak farklılıklar vardır.
Dolayısıyla en son xcode ve swift sürümünü kullanarak uygulamanızı geliştirmeye gayret edin. IOS versiyonları arası olası uyumsuzlukları belirleyip giderme sorumluluğu geliştiriciye aittir.

tarafından

Peki A uygulaması için 2 farklı ios sürümü yükleyebiliyormuyuz ?

tarafından

ancak iki farklı uygulama olarak yükleyebilirsin.
mesela uygulama adına ufak bir ek yaparsın.
örneğin;

"mySuperApp" -> IOS 8 altı için
"mySuperApp-HD" -> IOS 8 ve üstü için

ama bunlar temelde iki farklı uygulama olacağı appStore'da sıralanırken beraber listelenemeyebilirler.

...